NAT - Network Address Translation


Configuring Dynamic NAT: One Private to One Public Address Translation
======================================================

=> Define a static route on the remote router stating where the public address should be routed.
ISP(config)#ip route 203.3.3.64 255.255.255.128 s0/0/0

=> Define a pool of usable public IP addresses on your router that will perform NAT.
Corp(config)#ip nat pool mynat 203.3.3.70 203.3.3.126 netmask 255.255.255.128

=> Create an access control list (ACL) that will identify which private IP Addresses will be translated.
Corp(config)#access-list 10 permit 192.168.1.0 0.0.0.255

=> Link the ACL to the pool of addresses (create the translation).
Corp(config)#ip nat inside source list 10 pool mynat

=> Define which interface are inside.
Corp(config)#interface GigabitEthernet 0/0
Corp(config)#ip nat inside

=> Define the outside interface
Corp(config)#interface serial 0/0/0
Corp(config)#ip nat outside

Configuring PAT: Many Private to One Public Address Translation
================================================
=> Define a static route on the remote router stating where public address should be routed.
ISP(config)#ip route 203.3.3.64 255.255.255.128 s0/0/0

=> Define a pool of usable public IP addresses on your router that will perform NAT.
Corp(config)#ip nat pool mynat 203.3.3.70 203.3.3.70 netmask 255.255.255.128

=>Create an ACL that will identify when private IP addresses will be translated.
Corp(config)#access-list 10 permit 192.168.1.0 0.0.0.255

=> Link the ACL to the outside public interface
Corp(config)#ip nat inside source list 10 interface serial 0/0/0 overload

=> Link the ACL to the pool of addresses.
Corp(config)#ip nat inside source list 10 pool mynat overload

=> Define which interfaces are inside
Corp(config)#interface GigabitEthernet 0/0
Corp(config-if)#ip nat inside

=> Define the outside interface
Corp(config)#interface serial 0/0/0
Corp(config-if)#ip nat outside

Configuring Static NAT: One Private to One Permanent Public Address Translation
============================================================

=> Define a static route on the remote Router stating where the public addresses should be routed.
ISP(config)#ip route 203.3.3.64 255.255.255.128 serial 0/0/0

=> Create a static mapping on your router that will perform NAT.
Corp(config)#ip nat inside source static 192.168.1.10 203.3.3.70

=> Define which interfaces are inside
Corp(config)#interface GigabitEthernet
Corp(config-if)#ip nat inside

=> Define which inerface are outside interface
Corp(config)#interface serial 0/0/0
Corp(config-if)#ip nat outside

===Verifying NAT and PAT Configurations ====

Corp#show access-list
Corp#show ip nat translations
Corp#show ip nat statistics
Corp#clear ip nat translations inside x.x.x.x outside x.x.x.x
Corp#clear ip nat translations*
NAT - Network Address Translation NAT - Network Address Translation Reviewed by Anonymous on 8:23:00 AM Rating: 5